Bank connection failures
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted Nov 13, 2018 - 15:27 GMT
Investigating
One of our providers is having infrastructure problems which affects re-linking and changing bank accounts. We're in contact with them.
Posted Nov 13, 2018 - 12:16 GMT
This incident affected: 🏦 Bank Connections.