Banking partner outage
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted Oct 23, 2019 - 09:05 BST
Identified
Our Banking Provider is experiencing some technical issues which is affecting new users signing up. This may also mean existing users accounts aren't fully functioning. Pending deposits and all withdrawals are unaffected. If you are experiencing issues please try again tomorrow.
Posted Oct 22, 2019 - 17:25 BST
This incident affected: 🏦 Bank Connections.