HSBC Accounts not refreshing
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted 5 months ago. May 28, 2019 - 09:32 BST
Identified
Plum accounts linked to HSBC will find that their account is not refreshing (e.g. providing bank balance updates or making autosavings). This is due to HSBC site maintenance. It should be resolved in the next couple of days.

You will still be able to manually deposit/withdraw your funds
Posted 5 months ago. May 22, 2019 - 12:07 BST
This incident affected: 🏦 Bank Connections.