Withdrawal Delays
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted Sep 14, 2018 - 09:42 BST
Update
We have been informed that the delay is caused by some issues that Barclays is having, which means they are unable to process the withdrawal requests at the moment.
Posted Sep 13, 2018 - 17:43 BST
Update
We are continuing to investigate this issue.
Posted Sep 13, 2018 - 14:40 BST
Investigating
Our payment partner is experiencing delays with withdrawals requested yesterday afternoon and this morning. They are in the process of implementing a fix.
Posted Sep 13, 2018 - 14:24 BST
This incident affected: ⬅️ Withdrawals.