Withdrawal delays (Barclays cash management system unavailable)
Incident Report for Plum Fintech
Resolved
This issue has now been resolved and withdrawals are now being processed.
Posted Dec 07, 2018 - 17:36 GMT
Update
We are continuing to investigate this issue.
Posted Dec 07, 2018 - 14:21 GMT
Investigating
We have been informed that the Barclays cash management system is currently unavailable, which means that our partner Mangopay is unable to process withdrawal requests at the moment. We are in close contact with MangoPay and will keep you informed of the progress.
Posted Dec 07, 2018 - 11:08 GMT
This incident affected: ⬅️ Withdrawals.