Delayed sell-orders from Investments
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted Mar 03, 2021 - 16:26 GMT
Update
We are continuing to work on a fix for this issue.
Posted Mar 03, 2021 - 14:46 GMT
Update
We are continuing to work on a fix for this issue.
Posted Mar 03, 2021 - 14:40 GMT
Identified
We are currently investigating an issue with delayed sell-orders affecting small number of users. Our technical team is looking into this issue and is working very hard to fix it.
Posted Mar 03, 2021 - 13:04 GMT
This incident affected: 📈 Investments.