Deposits due 15 Oct delayed
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted Oct 17, 2019 - 10:07 BST
Identified
Due to operational issues deposits that were supposed to land 15 Oct have been delayed. We are very sorry about this and are working very hard to process them as quickly as possible. They should be in by tomorrow at the very latest.
Posted Oct 16, 2019 - 10:24 BST
This incident affected: ➡️ Deposits.