Connection issues with RBS, Natwest, and Ulsterbank
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted Apr 06, 2020 - 10:34 BST
Update
We are continuing to work on a fix for this issue.
Posted Apr 01, 2020 - 13:07 BST
Identified
There is currently issues with RBS connector that is making it difficult for users to link their RBS, Natwest, or Ulsterbank account. Our partner is working hard to fix the issue. We will update you once it is sorted.

In the meantime you can still manually withdraw/deposit funds.
Posted Mar 27, 2020 - 12:25 GMT
This incident affected: 🏦 Bank Connections.