Deposits due 20 November delayed
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted Nov 25, 2019 - 09:44 GMT
Identified
Due to operational issues deposits that were supposed to land 20 November have been delayed. We are very sorry about this and are working very hard to process them as quickly as possible. They should be in by Monday at the very latest, although they could land much earlier.
Posted Nov 21, 2019 - 11:16 GMT
This incident affected: ➡️ Deposits.