Deposits due 1-3 Nov delayed
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted Nov 11, 2019 - 09:35 GMT
Update
Due to a backlog, unfortunately deposits due from Friday until Tuesday are delayed until Wednesday. We are very sorry for this and tech is working to sort this asap. There is a chance the funds could arrive sooner but this cannot be guaranteed.
Posted Nov 05, 2019 - 09:45 GMT
Identified
Due to a bank Holiday in Luxembourg, where our partner is located, deposits and withdrawals that were supposed to land 1 November have been delayed. We are very sorry about this. They should be in by Monday, by the end of the day.
Posted Nov 02, 2019 - 11:00 GMT
This incident affected: ➡️ Deposits.