EU Direct Debit Deposits Delay

Incident Report for Plum Fintech

Resolved

This incident has been resolved.
Posted Feb 28, 2025 - 16:08 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 28, 2025 - 15:56 GMT

Investigating

We're aware that some of our customers in the EU region might be experiencing a delay in the settlement of their direct debits.

We'd like to reassure customers that deposits will be successfully completed, but at a slower pace than usual while the issue is being resolved.

We'd like to apologise for any inconvenience caused.

Please be assured that your money is always safe with Plum.
Posted Feb 28, 2025 - 12:51 GMT
This incident affected: ➡️ Deposits.