HSBC/First Direct connector down
Incident Report for Plum Fintech
Resolved
The issue impacting our HSBC Group connectors is now resolved. The bank has deployed a fix. We apologise for any inconvenience caused, and thank you for your patience.
Posted Sep 10, 2020 - 14:36 BST
Investigating
We have identified an issue which is preventing HSBC Group users (HSBC, HSBC Business, First Direct and M&S) from authenticating, making payments or get balance/transactions information. This is an unplanned downtime on the bank’s side.

We have contacted the bank and will advise here as soon as possible. . HSBC is currently working on a fix.

Your funds are always safe with Plum!
Posted Sep 10, 2020 - 11:30 BST
This incident affected: 🏦 Bank Connections.