Login Issues
Incident Report for Plum Fintech
Resolved
This incident has been resolved.

The Plum app should now be working as normal for all customers.

We apologise for any inconvenience caused. Rest assured that your money was always safe in the meantime.
Posted Oct 30, 2024 - 14:19 GMT
Monitoring
The issue has been identified, and a fix has been applied. The Plum app should now be working as normal for all customers.

We are closely monitoring the situation to ensure stability continues.

We apologise for any inconvenience and want to reassure you that your funds remained safe at all times.
Posted Oct 26, 2024 - 09:02 BST
Investigating
We're aware that some customers are experiencing issues logging into the app.

Our team is actively working to restore full access as quickly as possible.

We apologise for any inconvenience caused. Rest assured that your money is always safe in the meantime.
Posted Oct 25, 2024 - 19:12 BST
This incident affected: Plum application.