This incident has been resolved and all transactions are now settled.
We're sorry for any inconvenience caused.
Posted Jun 13, 2025 - 10:17 BST
Update
We are continuing to work on a fix for this issue.
Posted Jun 10, 2025 - 10:56 BST
Identified
We’re currently experiencing a delay in the settlement of some mutual fund orders. Our provider has confirmed the issue and is working to resolve it as quickly as possible.
Our team is actively monitoring the situation to ensure a swift resolution.
We apologise for the inconvenience this may cause.
Please rest assured that your money remains safe with us at all times.