Delayed saving deposits from 26.04.19
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted 6 months ago. Apr 30, 2019 - 12:20 BST
Identified
Due to an operational delay with MangoPay, saving deposits due to reach Plum accounts on Friday 26th April are late. Deposits should clear by Monday 29th April.
Posted 6 months ago. Apr 27, 2019 - 10:13 BST
This incident affected: ➡️ Deposits.