Delayed Sell-Orders and Buy-Orders
Incident Report for Plum Fintech
Resolved
We'd like to inform you that this incident has been resolved. All delayed orders have updated estimated completion dates now, either for the 28th or 29th April.

Thank you for your patience!
Posted Apr 22, 2021 - 13:17 BST
Update
We are continuing to work on a fix for the issue. In the meantime, a number of orders have been completed and there remain some to be settled. We will keep you updated!

Apologies for any inconvenience caused!
Posted Apr 21, 2021 - 09:37 BST
Update
We are continuing to work on a fix for this issue.
Posted Apr 19, 2021 - 13:54 BST
Identified
We have identified a delay in the estimated arrival of your investments deposits and withdrawals. A fix for this issue is being implemented from our technical team.
Posted Apr 17, 2021 - 09:18 BST
This incident affected: 📈 Investments.