Round-ups saver
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted Jul 29, 2020 - 14:54 BST
Update
We are continuing to monitor for any further issues.
Posted Jul 29, 2020 - 08:55 BST
Update
We are continuing to monitor for any further issues.
Posted Jul 29, 2020 - 08:50 BST
Monitoring
An issue affecting this week's round-up savers of some users has been identified and fixed. We would like to notify users affected that the saver will resume normally next week.

The saver will not be retried this week, however.

Apologies for any inconvenience caused!
Posted Jul 29, 2020 - 08:43 BST
This incident affected: Saver Rules.