Combo Depositor did not run
Incident Report for Plum Fintech
Resolved
We’ve now resolved the problem, and will reschedule the deposit to leave your bank on either Thursday (26th) or Friday (27th) this week.

We apologise for any inconvenience or confusion caused as a result of this.
Posted Jan 25, 2023 - 09:17 GMT
Investigating
We’re aware that some customers may have experienced an issue with their Combo Depositor that was scheduled to run today. Due to a technical issue, the deposit was not created.

We're currently investigating and will provide an update as soon as available.

We apologise for the inconvenience caused in the meantime.

Thank you very much for your patience!
Posted Jan 23, 2023 - 16:57 GMT
This incident affected: Depositors.