Partial Delay in Withdrawals due 9-10 May
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted 5 months ago. May 13, 2019 - 17:47 BST
Monitoring
Our partner is processing the delayed withdrawals. They should arrive in your Bank account by the end of the day today. We apologise again for this inconvenience.
Posted 5 months ago. May 13, 2019 - 13:32 BST
Investigating
We are currently experiencing a partial delay in Withdrawals that were due 9-10 May that have not arrived in your bank yet. Do not worry! Your funds are fine and will be returned to your bank ASAP. We are in contact with our partner Mangopay regarding this delay.
Posted 6 months ago. May 11, 2019 - 11:54 BST
This incident affected: ⬅️ Withdrawals.