UK customers not able to request withdrawals
Incident Report for Plum Fintech
Resolved
The incident is now closed.

The services are stable and the transactions processing as expected.

We would like to apologise once again for the inconvenience caused.

If you have any concerns, do not hesitate to contact our support team.
Posted Mar 10, 2023 - 14:52 GMT
Monitoring
A fix has been implemented and the service has been restored.

Our customers are now able to request withdrawals.

We'll continue monitor to ensure the fix is working.

We would like to apologise once again for the inconvenience caused by this temporary issue.
Posted Mar 08, 2023 - 17:32 GMT
Identified
We're aware that some UK customers might not be able to request withdrawals currently.

Rest assured that we're working as hard as we can to restore the service as soon as possible.

We would like to apologise for the inconvenience caused and assure you that your money is always safe in the meantime.
Posted Mar 08, 2023 - 17:27 GMT
This incident affected: ⬅️ Withdrawals.