Deposits delayed
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 10, 2019 - 14:41 BST
Update
Some savings due to complete on 30th to 5th June are still pending due to an operational backlog processing payments. If you have savings still pending from these dates, we are working to process the payments as fast as possible. We are very sorry for any inconvenience!
Posted 5 months ago. Jun 05, 2019 - 09:49 BST
Update
Some savings due to complete on 30th to 5th June are still pending due to an operational backlog processing payments. If you have savings still pending from these dates, we are working to process the payments as fast as possible. We are very sorry for any inconvenience!
Posted 5 months ago. Jun 05, 2019 - 00:00 BST
Update
We are continuing to work on a fix for this issue.
Posted 5 months ago. Jun 03, 2019 - 10:57 BST
Update
We are continuing to work on a fix for this issue.
Posted 5 months ago. Jun 03, 2019 - 10:46 BST
Identified
We are still experiencing delays with deposits - pending deposits due to settle on 30th and 31st May will reach Plum accounts this afternoon. We're very sorry for the inconvenience!
Posted 6 months ago. May 03, 2019 - 18:00 BST
This incident affected: ➡️ Deposits and ⬅️ Withdrawals.