Issues with banks disconnecting
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted Jul 21, 2020 - 08:29 BST
Monitoring
A fix has been implemented. Accounts will be gradually fixed.
Posted Jul 15, 2020 - 11:30 BST
Identified
We are currently having issues where you may be requested to relink your bank account, usually every other day. We are currently investigating the issue. We apologize for the inconvenience.

Bear in mind this will not affect your ability to manually deposit/withdraw funds.
Posted Jul 02, 2020 - 12:46 BST
This incident affected: 🏦 Bank Connections.