UK Ethical Fund Conversion in Progress
Incident Report for Plum Fintech
Resolved
The conversion process for the UK Ethical Fund has been finalised, and any balance discrepancies have been resolved.

Rest Assured your funds are always safe with Plum.

We apologise for any inconvenience this may have caused.
Posted Nov 25, 2024 - 14:22 GMT
Identified
The issue has been identified and a fix is being implemented.

Please be assured that your funds are safe and will reflect correctly once the fix is finalised.

We apologise for any inconvenience this may have caused.
Posted Nov 22, 2024 - 14:49 GMT
Investigating
We are aware that some users may notice discrepancies in their displayed balances for the UK Ethical Fund.
This is due to an ongoing conversion process. During this time, the fund is temporarily unavailable for trading.

Please be assured that your funds are safe and will reflect correctly once the process is finalised.

We apologise for any inconvenience this may have caused.
Posted Nov 16, 2024 - 18:57 GMT
This incident affected: 📈 Investments.