Deposits due 13 May delayed
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted 5 months ago. May 15, 2019 - 10:23 BST
Update
We are continuing to investigate this issue.
Posted 5 months ago. May 13, 2019 - 18:31 BST
Investigating
We are currently experiencing a delay with deposits due 13 May. We are in contact with our partner regarding this issue. We apologize for the inconvenience caused.
Posted 5 months ago. May 13, 2019 - 18:30 BST
This incident affected: ➡️ Deposits.