Deposits due 25 July and 26 July have been delayed
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 29, 2019 - 11:38 BST
Identified
Due to an operational issue deposits due into Plum accounts 25 (and likely 26th) July have been delayed. These savings should be fully settled by tomorrow evening. We are sorry for the inconvenience caused.
Posted 3 months ago. Jul 26, 2019 - 11:23 BST
This incident affected: ➡️ Deposits.