Delayed Buy-Orders and Sell-Orders
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted Sep 16, 2021 - 09:02 BST
Investigating
We are currently investigating a delay in the estimated arrival of some users' investment deposits and withdrawals. We are working on implementing a fix. We estimate that this is going to be resolved soon. Your funds are always safe!

Apologies for any inconvenience caused in the meantime.

Thank you for your patience!
Posted Sep 15, 2021 - 13:49 BST
This incident affected: 📈 Investments.