Deposits due 23 Oct delayed
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted Oct 28, 2019 - 09:43 GMT
Identified
Due to operational issues deposits that were supposed to land 23 Oct have been delayed. We are very sorry about this and are working very hard to process them as quickly as possible. They should be in by tomorrow at the very latest.
Posted Oct 24, 2019 - 10:29 BST
This incident affected: ➡️ Deposits.