Delayed Buy-Orders (deposits to investments)
Incident Report for Plum Fintech
Resolved
We would like to inform your that this incident has been resolved; all delayed buy-orders have been deposited to investments.

Thank you!
Posted Sep 07, 2021 - 15:33 BST
Identified
We are currently investigating a delay in the estimated arrival of some users' investment deposits. We are working on implementing a fix. We estimate that this is going to be resolved by tomorrow 08/09/2021 at the latest. Your funds are always safe!

Apologies for any inconvenience caused in the meantime.

Thank you for your patience!
Posted Sep 07, 2021 - 12:01 BST
This incident affected: 📈 Investments.