Delayed deposits and withdrawals
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted 6 months ago. May 03, 2019 - 17:54 BST
Update
We are continuing to work on a fix for this issue.
Posted 6 months ago. May 01, 2019 - 19:24 BST
Identified
Due to operational delays, deposits and withdrawals due to complete today 1st May are delayed. We have identified the issue and are working to process the payments as quickly as possible. Deposits and withdrawals due on 1st May should clear by 2nd May by the afternoon.
Posted 6 months ago. May 01, 2019 - 19:21 BST
This incident affected: ➡️ Deposits and ⬅️ Withdrawals.