Delays in Withdrawals

Incident Report for Plum Fintech

Resolved

This incident has been resolved.
Posted May 07, 2021 - 16:46 BST

Update

We are continuing to investigate this issue.
Posted Apr 30, 2021 - 12:09 BST

Investigating

We are currently investigating this issue.
Posted Apr 29, 2021 - 19:57 BST
This incident affected: ⬅️ Withdrawals.