Withdrawals delay
Incident Report for Plum Fintech
Resolved
Withdrawals from Plum to your bank account are functioning again.
Posted Nov 10, 2020 - 17:17 GMT
Investigating
We are aware of an issue affecting withdrawal of funds from Plum. We are working on a resolution and will update with more information.
Posted Nov 10, 2020 - 16:07 GMT
This incident affected: ⬅️ Withdrawals.