Delay in the settlement of Direct Debit deposits
Incident Report for Plum Fintech
Resolved
Please note that the incident is now resolved and all the Direct Debit deposits that were estimated to settle on January 5th, 6th and 7th have now reached your Plum account.

We would like to apologize once more for the inconvenience that we have caused.

If you have any issues or questions, please do not hesitate to reach out.
Posted Jan 09, 2022 - 17:36 GMT
Update
We are continuing to investigate this issue.
Posted Jan 07, 2022 - 10:15 GMT
Investigating
We are currently investigating a delay in the settlement of the Direct Debit deposits that were estimated to complete on January 5th.

Please rest assured that your money is always safe in the meantime and withdrawals are not affected.

We apologies for the inconvenience caused in the meantime.

Thank you very much for your patience!
Posted Jan 07, 2022 - 10:14 GMT
This incident affected: ➡️ Deposits.