Slow transactions processing speed
Incident Report for Plum Fintech
Resolved
The maintenance has been completed and the affected transactions have all been processed.

We would like to apologise once again for the inconvenience caused.

If you have any questions or face any issues, please do not hesitate to contact our support team.
Posted Mar 22, 2023 - 09:29 GMT
Investigating
We are aware that some customers might experience slower transactions processing speed due to platform maintenance from our provider. Deposits, withdrawals and transfers between pockets may be affected.

It means that the transactions will successfully complete but at a slower pace that usually expected.

We would like to apologise for the inconvenience caused and assure you that your money is always safe in the meantime.
Posted Mar 22, 2023 - 08:03 GMT
This incident affected: ➡️ Deposits and ⬅️ Withdrawals.