Discrepancies in Displayed Investments Balance - UK
Incident Report for Plum Fintech
Resolved
This incident has been resolved and the discrepancies are fixed.

We're sorry for any inconvenience caused.

Please be assured that your money is always safe with Plum.
Posted Jan 22, 2025 - 08:25 GMT
Monitoring
A fix has been implemented and we are monitoring the results.

This was solely a display issue; your actual Investment balance remains accurate and unaffected.

We're sorry for any inconvenience caused. Please be assured that your money is always safe with Plum.
Posted Jan 21, 2025 - 15:12 GMT
Identified
The issue has been identified and a fix is being implemented.

This is solely a display issue; your actual Investment balance remains accurate and unaffected.

We're sorry for any inconvenience caused.

Please be assured that your money is always safe with Plum.
Posted Jan 21, 2025 - 09:44 GMT
Investigating
We are aware that some users may notice discrepancies in their Investment balances.

This is solely a display issue; your actual Investment balance remains accurate and unaffected.

We’re currently investigating this and aim to resolve the issue as soon as possible.

We're sorry for any inconvenience caused. Please be assured that your money is always safe with Plum.
Posted Jan 20, 2025 - 19:43 GMT
This incident affected: 📈 Investments.