Login Issues on iOS Devices

Incident Report for Plum Fintech

Resolved

This incident has been resolved.
Posted Jul 28, 2025 - 11:12 BST

Update

We are continuing to monitor for any further issues.
Posted Jul 12, 2025 - 16:31 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 12, 2025 - 16:29 BST

Investigating

We recently experienced a connectivity issue that was preventing some iOS users from logging into the app.

A fix has been implemented and we are currently monitoring the situation to ensure everything is working as expected.

Users can now log in using either the phone number or the email linked to their Plum account.

We appreciate your patience and understanding.

Rest assured, your money has remained safe throughout.
Posted Jul 11, 2025 - 16:44 BST
This incident affected: Plum application.