Delayed Investments
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted Jun 18, 2020 - 09:27 BST
Update
The sell orders affected by last weeks delay are now due to complete on the 19th June. We're very sorry for any inconvenience!
Posted Jun 18, 2020 - 08:32 BST
Update
We are continuing to work on a fix for this issue.
Posted Jun 12, 2020 - 12:42 BST
Identified
We are currently experiencing a delay with some investments. Most of those affected are investments that were created towards the end of May and beginning of June. If your investment transaction is not showing to have a completion date (i.e. saying 'Should complete ____' and only showing the date) then it is one of the affected investments.

We do apologise for this. The engineers are fixing the issue and should be fixed in the next day or so. Once it is fixed the investment will be resubmitted and you will be provided a completion date. This should show on the app at some point early next week.
Posted Jun 12, 2020 - 12:17 BST
This incident affected: 📈 Investments.