Delayed deposits from 12.04.19
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted 6 months ago. Apr 13, 2019 - 16:32 BST
Update
We are continuing to work on a fix for this issue.
Posted 6 months ago. Apr 13, 2019 - 16:32 BST
Identified
Our Team have identified and now fixed the issue, all deposits still pending from yesterday will reach Plum accounts in the next few hours.
Posted 6 months ago. Apr 13, 2019 - 10:43 BST
Investigating
Due to an operational delay, deposits due to reach Plum accounts yesterday 12th April are still pending. Our Tech Team are working on getting this fixed as soon as possible!
Posted 6 months ago. Apr 13, 2019 - 10:29 BST
This incident affected: ➡️ Deposits.