Interest Pocket Withdrawal Delays - UK
Incident Report for Plum Fintech
Resolved
This incident has been resolved and all affected transactions have been settled.

We would like to apologise for any inconvenience caused and assure you that your money is always safe in the meantime.
Posted Dec 03, 2024 - 07:22 GMT
Investigating
We're aware that some customers are experiencing slower withdrawals from Interest pockets than usual.

Rest assured that the issue is currently being worked on and the affected withdrawals will be available as soon as possible.

We would like to apologise for any inconvenience caused and assure you that your money is always safe in the meantime.
Posted Nov 26, 2024 - 11:35 GMT
This incident affected: ⬅️ Withdrawals.