Cash ISA Activity Feed Display Issue

Incident Report for Plum Fintech

Resolved

This incident has been resolved.

We apologize for any inconvenience this may have caused.
Posted Mar 31, 2025 - 10:10 BST

Investigating

We're aware that some Customers are not able to view their Cash ISA Activity Feed.

We're working on resolving this issue as quickly as possible.

We apologize for any inconvenience this may cause and appreciate your patience during this time.
Posted Mar 29, 2025 - 19:26 GMT
This incident affected: Application interface.