App availability and Data loading
Incident Report for Plum Fintech
Resolved
This incident has been resolved and all operations have gone back to normal now.

Thank you for your patience!
Posted Nov 22, 2021 - 13:59 GMT
Monitoring
The issue has been identified and fixes applied.

The App usage is getting back to normal. We are still monitoring to make sure that this is resolved.
Posted Nov 22, 2021 - 13:35 GMT
Investigating
We are experiencing a connection issue with the App which may be preventing you from logging in or taking some actions within the app. It may also prevent the App from retrieving your profile information such as transactions list, pockets & funds balance, etc.

We are working to restore the App access and full functionalities as soon as possible.

Rest assured that your money is always safe in the meantime!

We're really sorry for the inconvenience!
Posted Nov 22, 2021 - 12:15 GMT
This incident affected: Plum application.