MangoPay Bank Holiday
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 12, 2019 - 10:04 BST
Identified
Just a reminder that due to a bank holiday with our partners based in Luxembourg no deposits or withdrawals are being processed today 10th June. If you withdrew over the weekend and today your money will be with you tomorrow afternoon. Deposits due to complete today will also settle tomorrow.
Posted 5 months ago. Jun 10, 2019 - 09:39 BST
This incident affected: ➡️ Deposits and ⬅️ Withdrawals.