Interest pockets withdrawals delays
Incident Report for Plum Fintech
Resolved
This incident has now been resolved and all Interest withdrawals have been processed.

The money should now be in your Pockets.

If you have any questions, please do not hesitate to reach out to our support team.
Posted Mar 08, 2023 - 17:18 GMT
Identified
We're aware that some customers are experiencing slower withdrawals from Interest pockets than usual. This is affecting a select amount of withdrawals which were requested on March 7th.

Rest assured that the issue is currently being worked on and the affected withdrawals will be available as soon as possible.

We would like to apologise for any inconvenience caused and assure you that your money is always safe in the meantime.

If you have any concerns about the status of your withdrawal please contact our support team.
Posted Mar 08, 2023 - 09:57 GMT
This incident affected: ⬅️ Withdrawals.