Mutual Funds Delay in Sell Orders Settlement - UK
Incident Report for Plum Fintech
Resolved
The incident has now been resolved.

All affected transactions have been processed and settled.

Once again, we apologise for any inconvenience this may have caused. Rest assured your money is always safe with Plum.
Posted Jul 08, 2024 - 09:31 BST
Identified
We are aware that some customers might experience a delay in the completion of their sell orders of mutual funds.

The issue has been identified and is being worked on by our Tech team with the highest priority.

Rest assured that your funds are always safe in the meantime.

We would like to apologise for the inconvenience caused.
Posted Jul 04, 2024 - 16:40 BST
This incident affected: ⬅️ Withdrawals.