Accounts not refreshing/unable to connect to bank
Incident Report for Plum Fintech
Resolved
We have worked with Yodlee to resolve the issue. It was identified as a fault in their refresh system. All accounts should refresh okay now.
Posted 6 months ago. Apr 20, 2019 - 09:42 BST
Update
We are continuing to investigate this issue.
Posted 6 months ago. Apr 19, 2019 - 16:38 BST
Investigating
We are having issues with Plum accounts fetching data. This could also affect new and old users trying to (re)link their bank accounts and are finding themselves stuck at "securely linking". Do not worry, this does not affect your ability to manually deposit/withdraw.
Posted 6 months ago. Apr 19, 2019 - 16:24 BST
This incident affected: 🏦 Bank Connections.