App Connectivity Issues
Incident Report for Plum Fintech
Resolved
The incident is now considered closed as our service is back to normal and stable.

Do not hesitate to reach out if you have any questions.
Posted Jan 30, 2023 - 08:33 GMT
Monitoring
The issue has been identified and fixed. Plum should be working as normal for all customers.

It was related to a network issue (DNS) that was quickly fixed from Plum’s side. We are monitoring the situation to ensure our services continue to remain stable.

We would like to apologise for the inconvenience caused and to reassure you that the security of your money was never compromised.

If you are still facing any issues, do not hesitate to contact our customer support team.
Posted Jan 25, 2023 - 11:37 GMT
Investigating
We're experiencing some connectivity issues which may be preventing you from logging in or taking some actions within the app. We're working hard to restore access to the app and full functionalities as quickly as possible.

We’re really sorry for any inconvenience. Rest assured that your money is always safe in the meantime!
Posted Jan 25, 2023 - 09:48 GMT
This incident affected: Plum application.