Deposits due 19 July are Delayed
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 23, 2019 - 09:33 BST
Identified
Deposits that were due 19 July have been delayed. I am sorry for the inconvenience caused. They should be in your Plum account by Monday evening at the latest.
Posted 3 months ago. Jul 20, 2019 - 11:00 BST
This incident affected: ➡️ Deposits.