Delayed Settlement for Some Stock Sell Orders

Incident Report for Plum Fintech

Resolved

This incident has been resolved.
Posted Jul 17, 2025 - 16:11 BST

Investigating

We are currently investigating this issue.
Posted Jul 15, 2025 - 08:21 BST
This incident affected: 📈 Investments.