Direct Debit Deposits Settlement Delay
Incident Report for Plum Fintech
Resolved
This incident has now been resolved and all affected transactions are settled.

Rest assured that your funds are always safe with Plum.

We apologise for any inconvenience caused.
Posted Oct 24, 2024 - 20:39 BST
Investigating
We're aware that some customers might be experiencing a delay in completing their Direct Debit Deposits.

The issue is being investigated and worked on by our Tech team with the highest priority.

Rest assured that your funds are always safe with Plum in the meantime.

We apologise for any inconvenience caused.
Posted Oct 23, 2024 - 08:44 BST
This incident affected: ➡️ Deposits.