UK - Direct Debit Deposits Settlement Delay

Incident Report for Plum Fintech

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 12:03 BST

Investigating

We're aware that some customers in the UK may be experiencing delays with their Direct Debit deposits that were due to settle on 2nd July.

The issue is being investigated and worked on by our Tech team with the highest priority.

Rest assured that your funds are safe in the meantime.

We apologise for any inconvenience caused.
Posted Jul 03, 2025 - 10:58 BST
This incident affected: ➡️ Deposits.