Deposits due 15 and 16 August are Delayed
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted 2 months ago. Aug 20, 2019 - 11:30 BST
Update
We are continuing to work on a fix for this issue.
Posted 2 months ago. Aug 17, 2019 - 11:02 BST
Identified
Due to systemic issues, deposits due 16 August have been delayed. We do apologise for this! We are working on processing them as quickly as we can. They should be by Monday evening at the latest.
Posted 2 months ago. Aug 17, 2019 - 10:58 BST
This incident affected: ➡️ Deposits.